javascript

webpack4 postcss-loader autoprefixer 無效問題


為了解決各家廠商css3規範的相容問題,需要使用webpack提供的postcss-loader和autoprefixer外掛。

官方文件:
在這裡插入圖片描述
在這裡插入圖片描述
也能簡寫這樣
{ loader: 'postcss-loader', options: { plugins: loader => [ require('autoprefixer') ] } },

發現並沒有生效。。。。。
在這裡插入圖片描述

需要設定支援哪些瀏覽器,必須設定支援的瀏覽器才會自動新增新增瀏覽器相容。
module.exports = { plugins: [ require('autoprefixer')({ browsers: ['last 15 versions'] }) ] };

然後就成功了,不過還是報了個警告。
在這裡插入圖片描述
在這裡插入圖片描述
意思大概就是,把 browsers改成overrideBrowserslist,就好了。

over~~

本文章已修改原文用詞符合繁體字使用者習慣使其容易閱讀

版權宣告:此處為CSDN博主「Nick_5」的原創文章,依據CC 4.0 BY-SA版權協議,轉載請附上原文出處連結及本宣告。

原文連結:https://blog.csdn.net/weixin_41877243/article/details/101295001